
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.titusvilleherald.com/content/tncms/live/" />
<meta name="keywords" content="obituaries" />
<meta name="news_keywords" content="obituaries" />
<meta name="description" content="Larry A. Manross Sr., 88, of Titusville, passed away on Thursday afternoon, Dec. 3, 2020, at Titusville Healthcare and Rehabilitation Center." />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg?resize=200%2C310" />
<meta property="og:image:width" content="200" />
<meta property="og:image:height" content="310" />
<meta property="og:title" content="Larry A. Manross Sr., 88" />
<meta property="og:description" content="Larry A. Manross Sr., 88, of Titusville, passed away on Thursday afternoon, Dec. 3, 2020, at Titusville Healthcare and Rehabilitation Center." />
<meta property="og:site_name" content="Titusville Herald" />
<meta property="og:section" content="Obituaries" />
<meta property="fb:app_id" content="880663095310201" />
<meta property="article:publisher" content="https://www.facebook.com/TheTitusvilleHerald/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TitusvilleSport" />
<meta name="twitter:image:alt" content="Larry A. Manross Sr." />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.5cfe8d2b6e902b79c4710d15b491c631.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.c9c732b035a293475d6df8121863ef5a.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto+Slab:700|Merriweather:400,600,700|Merriweather+Sans:400,700,600,300"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/tntslider.f0c083d16d9ead5fda668c00e19f96ba.css"/>
<style>/*<![CDATA[*/ #tncms-block-1600666 .tnt-prop-img { max-width: 75px; } #user-controls-1600447 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1600447 .tn-user-screenname, #user-controls-1600447 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1600447 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1600447 .dropdown-signup { font-size: 12px; } #user-controls-1600447 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1600447 .large-user-avatar { margin-right: 10px; } #user-controls-1600447 .large-user-controls { font-size: 12px; } #user-controls-1600447 .logout-btn { cursor: pointer; } #user-controls-1600447 .login-btn { background-color: #355e3b; border-color: #355e3b; } #user-controls-1600447 .login-btn:hover { text-decoration: underline; } @media screen and (min-width: 320px) { #ad-1802147 { min-height: 1px; min-width: 2px; } } @media screen and (min-width: 768px) { #ad-1802147 { min-height: 1px; min-width: 2px; } } @media screen and (min-width: 992px) { #ad-1802147 { min-height: 1px; min-width: 2px; } } @media screen and (min-width: 1200px) { #ad-1802147 { min-height: 1px; min-width: 2px; } } .follow-links-1600444 li { margin-right: 1px; padding: 0; } .follow-links-1600444 li a, .follow-links-1600444 li a:focus, .follow-links-1600444 li a:active { ; color: #355e3b!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1600444 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1600444 li a.fb:hover { color: #3A59A5; } .follow-links-1600444 li a.tw:hover { color: #46C8F9; } #user-controls-1600446 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1600446 .tn-user-screenname, #user-controls-1600446 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1600446 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1600446 .dropdown-signup { font-size: 12px; } #user-controls-1600446 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1600446 .large-user-avatar { margin-right: 10px; } #user-controls-1600446 .large-user-controls { font-size: 12px; } #user-controls-1600446 .logout-btn { cursor: pointer; } #user-controls-1600446 .login-btn { background-color: #355e3b; border-color: #355e3b; } #user-controls-1600446 .login-btn:hover { text-decoration: underline; } #tncms-block-1600394 .tnt-prop-img { max-width: 1483px; } #block-1600442 .search-spinner { position: absolute; } #block-1600442 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1600442-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1600442-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1600442-dropdown .pull-right { float: none!important; } #site-search-1600442-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } #site-search-1600442-btn { background-color: #284D2A; border-color: #284D2A; } #tncms-block-1600439 .tnt-prop-img { max-width: 1483px; } @media screen and (min-width: 992px) { #ad-1685429 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 1200px) { #ad-1685429 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 992px) { #ad-1685433 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 1200px) { #ad-1685433 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 320px) { #ad-1600337 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1600337 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 992px) { #ad-1600337 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 1200px) { #ad-1600337 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 320px) { #ad-1728667 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1728667 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 320px) { #ad-1728667 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1728667 { min-height: 50px; min-width: 320px; } } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/obituaries","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":232},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"26275634-3691-11eb-ac3e-af2aa9888fae","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/14870/cc.js?ns=_cc14870" id="LOTCC_14870"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc14870.add('tp', 'TNNW');
		_cc14870.add('act', ' User Login');
		_cc14870.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc14870.bcp();
</script>

<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["obituaries"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.834cbe7aa25c4d789bfb4c362348b677.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/titusvilleherald.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/titusvilleherald.com/obituaries';
            
                gptAdSlots['ad-1802147'] = googletag.defineSlot(adUnit, [2,1], 'ad-1802147').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1802147'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/titusvilleherald.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1685429'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1685429').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1685429'].setTargeting('pos', ['rail-top']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/tntslider.d6fa00424f147b547e84bc3357fd371e.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/titusvilleherald.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], []).addSize([768, 0], []).addSize([992, 0], [[300,250],[300,600]]).addSize([1200, 0], [[300,250],[300,600]]).build();
                gptAdSlots['ad-1685433'] = googletag.defineSlot(adUnit, [[300,250],[300,600]], 'ad-1685433').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1685433'].setTargeting('pos', ['rail-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/titusvilleherald.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [728,90]).addSize([992, 0], [[728,90],[970,90],[970,250]]).addSize([1200, 0], [[728,90],[970,90],[970,250]]).build();
                gptAdSlots['ad-1600337'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90],[970,90],[970,250]], 'ad-1600337').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1600337'].setTargeting('pos', ['leaderboard-bottom']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/titusvilleherald.com/obituaries';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[320, 50], [728, 90]]).addSize([992, 0], []).addSize([1200, 0], []).build();
                gptAdSlots['ad-1728667'] = googletag.defineSlot(adUnit, [[320,50],[728,90]], 'ad-1728667').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1728667'].setTargeting('pos', ['leaderboard-sticky']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Larry A. Manross Sr., 88 | Obituaries | titusvilleherald.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #000; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #efefef; } #site-footer-container, #site-footer { background-color: #355e3b; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #000; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-top-nav .list-inline>li>a.btn:not(.btn-link) { color: #fff; }#site-copyright a, #site-footer a { color: #fff; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #aaa; }#site-header-container{ border-bottom: 3px solid #aaa; }#site-footer-container{ border-top: 3px solid #aaa; } .tnt-bg-accent { background-color: #aaa; } a .tnt-caret-down { color: #aaa; } .block-title .block-title-inner { border-color: #aaa; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #aaa; } .form-control:focus { border-bottom-color: #aaa; } .custom-signup-notice { font-weight: bold; font-style: italic; } </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style>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</style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/841f7d22-1b8d-11ea-9948-637a37b1aa7f.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Larry A. Manross Sr., 88 | Obituaries | titusvilleherald.com" href="http://www.titusvilleherald.com/search/?f=rss&amp;t=article&amp;c=obituaries&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" />
            <script defer src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <script language="javascript" type="text/javascript">
$(document).ready(function() {     
         
           
     $(".add-arrow .pos-bottom li a").append(' <i class="fa fa-arrow-circle-right"></i>');
     $('.footer-search .btn-link ').html('<i class="fa tnt-search" aria-hidden="true"></i>');
     $('.user-controls .not-logged-in .btn-link.user-control-link').text('Register');
    
    
     

      
 }); 
</script>


        </head>
        <body class="fixed-scroll-nav app-editorial grid-banded blox-asset uuid-26275634-3691-11eb-ac3e-af2aa9888fae section-obituaries type-article infinity-disabled" data-path="/obituaries">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.titusvilleherald.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=banded&tncms.page.style=default&tncms.page.path=%2Fobituaries&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.system.render_time=232&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=26275634-3691-11eb-ac3e-af2aa9888fae&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.titusvilleherald.com/tncms/admin/editorial-asset/?edit=26275634-3691-11eb-ac3e-af2aa9888fae"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1600666" class="tncms-block small-logo hidden-sm hidden-xs"><section id="block-1600666" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/84aeb4aa-8558-11e8-98e2-a78ab23fabbf.png" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div><div id="tncms-block-1600447" class="tncms-block text-center"><div id="user-controls-1600447" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.titusvilleherald.com/users/signup/?referer_url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.titusvilleherald.com/users/login/?referer_url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="btn btn-success btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.titusvilleherald.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1600447').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.titusvilleherald.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.titusvilleherald.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.titusvilleherald.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1600447').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.titusvilleherald.com/users/logout/" id="user-logout-form-1600447"><input type="hidden" name="referer_url" value="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a href="/site/privacy.html"  class="nav-link tnt-section-privacy-policy">Privacy Policy</a>
                                </li><li>
                                    <a href="/site/terms.html"  class="nav-link tnt-section-terms-of-use">Terms of Use</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-forms">Forms</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/announcements/anniversary/"  class="nav-link tnt-section-anniversary">Anniversary</a>
                                </li><li>
                                    <a href="/site/forms/announcements/wedding/"  class="nav-link tnt-section-wedding">Wedding</a>
                                </li><li>
                                    <a href="/site/forms/announcements/engagement/"  class="nav-link tnt-section-engagement">Engagement</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-ae">A&E</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar/community/"  class="nav-link tnt-section-community-calendar">Community Calendar</a>
                                </li><li>
                                    <a href="/arts_and_entertainment/entertainment/"  class="nav-link tnt-section-entertainment-news">Entertainment News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/country_letters/"  class="nav-link tnt-section-country-correspondents">Country Correspondents</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/country_letters/cherrytree/"  class="nav-link tnt-section-cherrytree">Cherrytree</a>
                                </li><li>
                                    <a href="/country_letters/diamond/"  class="nav-link tnt-section-diamond">Diamond</a>
                                </li><li>
                                    <a href="/country_letters/enterprise/"  class="nav-link tnt-section-enterprise">Enterprise</a>
                                </li><li>
                                    <a href="/country_letters/grand_valley/"  class="nav-link tnt-section-grand-valley">Grand Valley</a>
                                </li><li>
                                    <a href="/country_letters/hydetown/"  class="nav-link tnt-section-hydetown">Hydetown</a>
                                </li><li>
                                    <a href="/country_letters/pleasantville/"  class="nav-link tnt-section-pleasantville">Pleasantville</a>
                                </li><li>
                                    <a href="/country_letters/townville/"  class="nav-link tnt-section-townville">Townville</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/gallery"  class="nav-link tnt-section-photo-gallery">Photo Gallery</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/news/community_news/"  class="nav-link tnt-section-community-news">Community News</a>
                                </li><li>
                                    <a href="/news/feature_stories/"  class="nav-link tnt-section-feature-news">Feature News</a>
                                </li><li>
                                    <a href="/news/local_news/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a href="/news/state_news/"  class="nav-link tnt-section-state-news">State News</a>
                                </li><li>
                                    <a href="/news/national_news/"  class="nav-link tnt-section-national-news">National News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-8" data-target="#mobile-nav-left_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/local_sports/"  class="nav-link tnt-section-local-sports">Local Sports</a>
                                </li><li>
                                    <a href="/sports/titusville_sports/"  class="nav-link tnt-section-titusville-sports">Titusville Sports</a>
                                </li><li>
                                    <a href="/sports/maplewood_sports/"  class="nav-link tnt-section-maplewood-sports">Maplewood Sports</a>
                                </li><li>
                                    <a href="/sports/professional_sports/"  class="nav-link tnt-section-professional-sports">Professional Sports</a>
                                </li><li>
                                    <a href="/sports/college_sports/"  class="nav-link tnt-section-college-sports">College Sports</a>
                                </li><li>
                                    <a href="/sports/ap_sports/"  class="nav-link tnt-section-associated-press-sports">Associated Press Sports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-e-editions">e-Editions</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/eedition/"  class="nav-link tnt-section-the-titusville-herald">The Titusville Herald</a>
                                </li><li>
                                    <a href="/eedition_myforestpress/"  class="nav-link tnt-section-my-forest-press">My Forest Press</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/special/"  class="nav-link tnt-section-special-publications">Special Publications</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-11" data-target="#mobile-nav-left_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/site/forms/subscription_services"  class="nav-link tnt-section-subscription-services">Subscription Services</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/subscription_services/subscribe/subscribe/"  class="nav-link tnt-section-subscribe-to-the-herald">Subscribe to The Herald</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/vacation/"  class="nav-link tnt-section-pause-subscription">Pause subscription</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/changeaddress/"  class="nav-link tnt-section-update-subscription-address">Update subscription address</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/deliveryissue/delivery_issues_imported-20131029170244/"  class="nav-link tnt-section-report-delivery-issue">Report delivery issue</a>
                                </li><li>
                                    <a href="/site/forms/subscription_services/giftsubscribe/gift_subscribe/"  class="nav-link tnt-section-gift-a-subscription">Gift a subscription</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-12" data-target="#mobile-nav-left_menu-child-12">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-12" class="collapse nav navbar-nav"><li>
                                    <a href="/place_an_ad/"  class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li><li>
                                    <a href="/classifieds"  class="nav-link tnt-section-view-classifieds">View Classifieds</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-13" data-target="#mobile-nav-left_menu-child-13">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a   class="nav-link tnt-section-advertising">Advertising</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-13" class="collapse nav navbar-nav"><li>
                                    <a href="/site/advertising.html"  class="nav-link tnt-section-ad-rates">Ad Rates</a>
                                </li><li>
                                    <a href="/site/commercial_printing.html"  class="nav-link tnt-section-printing-services">Printing Services</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1802147" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1802147" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1802147');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "><div id="tncms-block-1600444" class="tncms-block pull-left padding-left"><div class="follow-links-1600444 default">
    
    <section id="block-1600444" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/TheTitusvilleHerald/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/@TitusvilleSport" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.titusvilleherald.com",
  "sameAs" : ["https://www.facebook.com/TheTitusvilleHerald/","https://twitter.com/@TitusvilleSport"]
}
</script>
<div class="clearfix"></div></div></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1600446" class="tncms-block"><div id="user-controls-1600446" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.titusvilleherald.com/users/signup/?referer_url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.titusvilleherald.com/users/login/?referer_url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.titusvilleherald.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1600446').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.titusvilleherald.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.titusvilleherald.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.titusvilleherald.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1600446').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.titusvilleherald.com/users/logout/" id="user-logout-form-1600446"><input type="hidden" name="referer_url" value="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1600633" class="tncms-block"><p class="pull-right padding-right"><strong><a href="/site/forms/subscription_services/">Subscription Services</a></strong></p></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1600394" class="tncms-block"><section id="block-1600394" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=300%2C37 300w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=400%2C50 400w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=540%2C67 540w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=750%2C93 750w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png?resize=1200%2C149 1200w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/d0d732a2-8559-11e8-bb41-cbce69592b50.png 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1600442" class="tncms-block"><ul id="site-search-1600442-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1600442" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-1600442-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1600442-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1600442-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1600442').submit();
        return false;
    });

    $('#site-search-1600442').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1600442 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1600442 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1600442-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1600439" class="tncms-block"><section id="block-1600439" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=200%2C25 200w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=300%2C37 300w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=400%2C50 400w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=540%2C67 540w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=750%2C93 750w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png?resize=1200%2C149 1200w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/custom/image/5e4ec1e2-855d-11e8-af50-ffd79dd3c196.png 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-about-us"  href="/site/about.html" >
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/site/contact.html" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link  tnt-section-privacy-policy"  href="/site/privacy.html" >
                    <span class="nav-label">Privacy Policy</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-use"  href="/site/terms.html" >
                    <span class="nav-label">Terms of Use</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-forms"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Forms</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-anniversary"  href="/site/forms/announcements/anniversary/" >
                    <span class="nav-label">Anniversary</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wedding"  href="/site/forms/announcements/wedding/" >
                    <span class="nav-label">Wedding</span>
                </a></li><li>
                <a class="nav-link  tnt-section-engagement"  href="/site/forms/announcements/engagement/" >
                    <span class="nav-label">Engagement</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-ae"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">A&E</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-community-calendar"  href="/calendar/community/" >
                    <span class="nav-label">Community Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-entertainment-news"  href="/arts_and_entertainment/entertainment/" >
                    <span class="nav-label">Entertainment News</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-country-correspondents"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/country_letters/" >
                    <span class="nav-label">Country Correspondents</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-cherrytree"  href="/country_letters/cherrytree/" >
                    <span class="nav-label">Cherrytree</span>
                </a></li><li>
                <a class="nav-link  tnt-section-diamond"  href="/country_letters/diamond/" >
                    <span class="nav-label">Diamond</span>
                </a></li><li>
                <a class="nav-link  tnt-section-enterprise"  href="/country_letters/enterprise/" >
                    <span class="nav-label">Enterprise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-grand-valley"  href="/country_letters/grand_valley/" >
                    <span class="nav-label">Grand Valley</span>
                </a></li><li>
                <a class="nav-link  tnt-section-hydetown"  href="/country_letters/hydetown/" >
                    <span class="nav-label">Hydetown</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pleasantville"  href="/country_letters/pleasantville/" >
                    <span class="nav-label">Pleasantville</span>
                </a></li><li>
                <a class="nav-link  tnt-section-townville"  href="/country_letters/townville/" >
                    <span class="nav-label">Townville</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-multimedia"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Multimedia</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-photo-gallery"  href="/gallery" >
                    <span class="nav-label">Photo Gallery</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-community-news"  href="/news/community_news/" >
                    <span class="nav-label">Community News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-feature-news"  href="/news/feature_stories/" >
                    <span class="nav-label">Feature News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/local_news/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-state-news"  href="/news/state_news/" >
                    <span class="nav-label">State News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national-news"  href="/news/national_news/" >
                    <span class="nav-label">National News</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-sports"  href="/sports/local_sports/" >
                    <span class="nav-label">Local Sports</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-titusville-sports"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/titusville_sports/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Titusville Sports</span>
                </a><ul id="main-nav_menu-child-8-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-baseball"  href="/sports/titusville_sports/baseball/" >
                    <span class="nav-label">Baseball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-boys-basketball"  href="/sports/titusville_sports/boys_basketball/" >
                    <span class="nav-label">Boys Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-boys-soccer"  href="/sports/titusville_sports/boys_soccer/" >
                    <span class="nav-label">Boys Soccer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cross-country"  href="/sports/titusville_sports/cross_country/" >
                    <span class="nav-label">Cross Country</span>
                </a></li><li>
                <a class="nav-link  tnt-section-football"  href="/sports/titusville_sports/football/" >
                    <span class="nav-label">Football</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-basketball"  href="/sports/titusville_sports/girls_basketball/" >
                    <span class="nav-label">Girls Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-soccer"  href="/sports/titusville_sports/girls_soccer/" >
                    <span class="nav-label">Girls Soccer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-volleyball"  href="/sports/titusville_sports/girls_volleyball/" >
                    <span class="nav-label">Girls Volleyball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-golf"  href="/sports/titusville_sports/golf/" >
                    <span class="nav-label">Golf</span>
                </a></li><li>
                <a class="nav-link  tnt-section-softball"  href="/sports/titusville_sports/softball/" >
                    <span class="nav-label">Softball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-swimming"  href="/sports/titusville_sports/swimming/" >
                    <span class="nav-label">Swimming</span>
                </a></li><li>
                <a class="nav-link  tnt-section-tennis"  href="/sports/titusville_sports/tennis/" >
                    <span class="nav-label">Tennis</span>
                </a></li><li>
                <a class="nav-link  tnt-section-track-field"  href="/sports/titusville_sports/track_and_field/" >
                    <span class="nav-label">Track & Field</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wrestling"  href="/sports/titusville_sports/wrestling/" >
                    <span class="nav-label">Wrestling</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-maplewood-sports"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/sports/maplewood_sports/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Maplewood Sports</span>
                </a><ul id="main-nav_menu-child-8-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-baseball"  href="/sports/maplewood_sports/baseball/" >
                    <span class="nav-label">Baseball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-boys-basketball"  href="/sports/maplewood_sports/boys_basketball/" >
                    <span class="nav-label">Boys Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-boys-volleyball"  href="/sports/maplewood_sports/boys_volleyball/" >
                    <span class="nav-label">Boys Volleyball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cross-country"  href="/sports/maplewood_sports/cross_country/" >
                    <span class="nav-label">Cross Country</span>
                </a></li><li>
                <a class="nav-link  tnt-section-football"  href="/sports/maplewood_sports/football/" >
                    <span class="nav-label">Football</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-basketball"  href="/sports/maplewood_sports/girls_basketball/" >
                    <span class="nav-label">Girls Basketball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-soccer"  href="/sports/maplewood_sports/girls_soccer/" >
                    <span class="nav-label">Girls Soccer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-girls-volleyball"  href="/sports/maplewood_sports/girls_volleyball/" >
                    <span class="nav-label">Girls Volleyball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-golf"  href="/sports/maplewood_sports/golf/" >
                    <span class="nav-label">Golf</span>
                </a></li><li>
                <a class="nav-link  tnt-section-softball"  href="/sports/maplewood_sports/softball/" >
                    <span class="nav-label">Softball</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wrestling"  href="/sports/maplewood_sports/wrestling/" >
                    <span class="nav-label">Wrestling</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-professional-sports"  href="/sports/professional_sports/" >
                    <span class="nav-label">Professional Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-college-sports"  href="/sports/college_sports/" >
                    <span class="nav-label">College Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-associated-press-sports"  href="/sports/ap_sports/" >
                    <span class="nav-label">Associated Press Sports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-e-editions"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">e-Editions</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-the-titusville-herald"  href="/eedition/" >
                    <span class="nav-label">The Titusville Herald</span>
                </a></li><li>
                <a class="nav-link  tnt-section-my-forest-press"  href="/eedition_myforestpress/" >
                    <span class="nav-label">My Forest Press</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-special-publications"  href="/special/" >
                    <span class="nav-label">Special Publications</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-subscription-services"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/forms/subscription_services" >
                    <span class="nav-label">Subscription Services</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-subscribe-to-the-herald"  href="/site/forms/subscription_services/subscribe/subscribe/" >
                    <span class="nav-label">Subscribe to The Herald</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pause-subscription"  href="/site/forms/subscription_services/vacation/" >
                    <span class="nav-label">Pause subscription</span>
                </a></li><li>
                <a class="nav-link  tnt-section-update-subscription-address"  href="/site/forms/subscription_services/changeaddress/" >
                    <span class="nav-label">Update subscription address</span>
                </a></li><li>
                <a class="nav-link  tnt-section-report-delivery-issue"  href="/site/forms/subscription_services/deliveryissue/delivery_issues_imported-20131029170244/" >
                    <span class="nav-label">Report delivery issue</span>
                </a></li><li>
                <a class="nav-link  tnt-section-gift-a-subscription"  href="/site/forms/subscription_services/giftsubscribe/gift_subscribe/" >
                    <span class="nav-label">Gift a subscription</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-12" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="/place_an_ad/" >
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-view-classifieds"  href="/classifieds" >
                    <span class="nav-label">View Classifieds</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-advertising"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    <span class="nav-label">Advertising</span>
                </a><ul id="main-nav_menu-child-13" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-ad-rates"  href="/site/advertising.html" >
                    <span class="nav-label">Ad Rates</span>
                </a></li><li>
                <a class="nav-link  tnt-section-printing-services"  href="/site/commercial_printing.html" >
                    <span class="nav-label">Printing Services</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><div id="modal-image-4293a340-3691-11eb-802d-e7660211f267" class="modal fullscreen in modal-image image-default modal-4293a340-3691-11eb-802d-e7660211f267" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg"
                    srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg?resize=100%2C155"
                    sizes="100vw"
                    width="100"
                    height="155"
                    alt="Larry A. Manross Sr."
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-4293a340-3691-11eb-802d-e7660211f267" data-target=".caption-inner-modal-image-4293a340-3691-11eb-802d-e7660211f267">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-4293a340-3691-11eb-802d-e7660211f267 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Fimage_4293a340-3691-11eb-802d-e7660211f267.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/image_4293a340-3691-11eb-802d-e7660211f267.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Larry%20A.%20Manross%20Sr.&via=TitusvilleSport&url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Fimage_4293a340-3691-11eb-802d-e7660211f267.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/image_4293a340-3691-11eb-802d-e7660211f267.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.titusvilleherald.com/obituaries/image_4293a340-3691-11eb-802d-e7660211f267.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/image_4293a340-3691-11eb-802d-e7660211f267.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.titusvilleherald.com/tncms/asset/editorial/4293a340-3691-11eb-802d-e7660211f267" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTitusvilleHerald.com%5D%20Larry%20A.%20Manross%20Sr.&body=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Fimage_4293a340-3691-11eb-802d-e7660211f267.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/image_4293a340-3691-11eb-802d-e7660211f267.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4293a340-3691-11eb-802d-e7660211f267"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-4293a340-3691-11eb-802d-e7660211f267-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="4293a340-3691-11eb-802d-e7660211f267" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="4293a340-3691-11eb-802d-e7660211f267" class="save-list-4293a340-3691-11eb-802d-e7660211f267-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="4293a340-3691-11eb-802d-e7660211f267" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-4293a340-3691-11eb-802d-e7660211f267 img { max-height: 155px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-26275634-3691-11eb-ac3e-af2aa9888fae" class="asset article-default"  data-url="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg?resize=200%2C310">
            <meta itemprop="width" content="200">
            <meta itemprop="height" content="310">
        </div>
        <meta itemprop="name" content="titusvilleherald.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" />
    <style>
                .asset-paging .direction {
                    color: #aaa;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":true,"nextUrl":"https:\/\/www.titusvilleherald.com\/tncms\/search\/mlt\/?origin=26275634-3691-11eb-ac3e-af2aa9888fae&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-26275634-3691-11eb-ac3e-af2aa9888fae" class="asset-paging">
                <div id="paging-prev-26275634-3691-11eb-ac3e-af2aa9888fae" class="paging-link prev offset"></div>
                <div id="paging-next-26275634-3691-11eb-ac3e-af2aa9888fae" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Larry A. Manross Sr., 88
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-12-05T05:00:00-05:00" class="tnt-date asset-date text-muted">
            Dec 5, 2020
        </time></li>
            <li class="hidden-print">
        <time datetime="2020-12-05T05:00:00-05:00" class="tnt-date asset-date text-muted">6 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-12-05T05:00:00-05:00">
    <meta itemprop="datePublished" content="2020-12-05T05:00:00-05:00">
    <meta itemprop="dateModified" content="2020-12-05T05:00:00-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Larry%20A.%20Manross%20Sr.%2C%2088&via=TitusvilleSport&url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.titusvilleherald.com/tncms/asset/editorial/26275634-3691-11eb-ac3e-af2aa9888fae" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTitusvilleHerald.com%5D%20Larry%20A.%20Manross%20Sr.%2C%2088&body=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-4293a340-3691-11eb-802d-e7660211f267" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-4293a340-3691-11eb-802d-e7660211f267" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="100">
            <meta itemprop="height" content="155">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg"
                    srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/editorial/4/29/4293a340-3691-11eb-802d-e7660211f267/5fcad53bd422c.image.jpg?resize=100%2C155"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="100"
                    height="155"
                    alt="Larry A. Manross Sr."
                    class="img-responsive  letterbox tnt-restrict-img-4293a340-3691-11eb-802d-e7660211f267 default" />
            </div><style>
                .tnt-restrict-img-4293a340-3691-11eb-802d-e7660211f267 {
                    max-width: 100px;
                }
            </style>
                
                
            </div>
            
                
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="26275634-3691-11eb-ac3e-af2aa9888fae" data-smart-adunit="/132916964/titusvilleherald.com/obituaries">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Larry%20A.%20Manross%20Sr.%2C%2088&via=TitusvilleSport&url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.titusvilleherald.com/tncms/asset/editorial/26275634-3691-11eb-ac3e-af2aa9888fae" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTitusvilleHerald.com%5D%20Larry%20A.%20Manross%20Sr.%2C%2088&body=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-26275634-3691-11eb-ac3e-af2aa9888fae-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="26275634-3691-11eb-ac3e-af2aa9888fae" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="26275634-3691-11eb-ac3e-af2aa9888fae" class="save-list-26275634-3691-11eb-ac3e-af2aa9888fae-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="26275634-3691-11eb-ac3e-af2aa9888fae" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p class="p1">Larry A. Manross Sr., 88, of Titusville, passed away on Thursday afternoon, Dec. 3, 2020, at Titusville Healthcare and Rehabilitation Center.</p><p class="p1">Larry was born on Aug. 24, 1932, in Titusville, a son of the late Melvin and Claribell Millard Manross. He was married to Myrna Hepler on June 30, 1951, in Titusville. She preceded him in death on May 20, 2018.</p><p class="p1">Larry had been employed in the maintenance department at the former National City Bank, as well as with Integra Bank. He had also worked at the former Rowe’s Greenhouse.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p class="p1">Larry had attended the Bible Baptist Church.<span class="Apple-converted-space"> </span></p><p class="p1">He is survived by two sons, Larry A. Manross Jr. and wife, Norma, of Titusville, and Danny A. Manross and companion, Roberta Jansen, of Chapmanville; four daughters, Bonnie Brown and husband, Roger, of Chapmanville, Cheryl Brown and husband, Larry, of Thornville, Ohio, Jenine Goodwill, and Teresa Conner and husband, Ross, both of Titusville; a daughter-in-law, Gloria Manross, of Titusville; 12 grandchildren, Pepsi Harcourt, of Hermitage, Larry Manross III and wife, Paulynn, of Monkton, Maryland, Shasta Manross, of Centerville, Shelby Cancilla and husband, Joe, of Waterford, Shane Mietus and wife, Wendy, of Grove Port, Ohio, Joshua Mietus, of Meadville, Justin Goodwill, of Titusville, Grace Chopak and husband, Travis, of Grove City, Marie Goodwill, of Titusville, Jessica Conner, of Titusville, Ross Conner II and wife, Ashley, of Centerville, and Cheyenne Gutberlet and husband, Adam, of Titusville; 14 great- grandchildren; a brother, Paul Manross, of Denver, Colorado, and numerous nieces and nephews.</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p class="p1">In addition to his parents and wife, he was preceded in death by a son, Scott David Manross; a grandson, Kevin Fiely; a son-in-law, Harold Goodwill Jr.; two brothers, Thomas and Melvin Manross; and a grandson-in-law, Brian Gisewhite.<span class="Apple-converted-space"> </span></p><p class="p1">No public calling hours will be observed. A private funeral service for the family will be conducted from the Gordon B. Garrett Funeral Home, 303 N. Washington St., Titusville, Pa. 16354.</p><p class="p1">Interment will be in Woodlawn Cemetery.</p><p class="p1">The family asks that memorials be made to St. Jude’s Children’s Research Hospital, 262 Danny Thomas Place, Memphis, Tenn. 38105.</p><p class="p1">If you wish to leave a condolence for the family, visit <a href="http://garrettfuneralhomeinc.com">garrettfuneralhomeinc.com</a>.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Larry%20A.%20Manross%20Sr.%2C%2088&via=TitusvilleSport&url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.titusvilleherald.com/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.titusvilleherald.com/tncms/asset/editorial/26275634-3691-11eb-ac3e-af2aa9888fae" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BTitusvilleHerald.com%5D%20Larry%20A.%20Manross%20Sr.%2C%2088&body=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-26275634-3691-11eb-ac3e-af2aa9888fae-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="26275634-3691-11eb-ac3e-af2aa9888fae" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="26275634-3691-11eb-ac3e-af2aa9888fae" class="save-list-26275634-3691-11eb-ac3e-af2aa9888fae-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="26275634-3691-11eb-ac3e-af2aa9888fae" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1791747" class="tncms-block"><section id="block-1791747" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1791747 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-1791747" class="card-grid-behavioral card-grid card-img- card-compact"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-1791747" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div><div id="taboola-video-outstream"></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="26275634-3691-11eb-ac3e-af2aa9888fae" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="26275634-3691-11eb-ac3e-af2aa9888fae" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.titusvilleherald.com/users/login/?referer_url=https%3A%2F%2Fwww.titusvilleherald.com%2Fobituaries%2Farticle_26275634-3691-11eb-ac3e-af2aa9888fae.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1685429" class="tncms-block padding-bottom"><div class="tnt-ads-container text-center  " >
        <div id="ad-1685429" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1685429');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1600432" class="tncms-block hide-body hide-headline">
    <section id="block-1600432" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1600432 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/classifieds/other/ads/">
                
                Ads From Today's Paper
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    <div class="slideshow-carousel-container">
        
            <div id="carousel-1600432" class="card photo-carousel subscriber-hide letterbox-style-default">
            <template data-id="1600432" class="tnt-slider-template" data-auto-slide="true" data-swipe="true" data-arrows="true" data-auto-height="true" data-lazy-load="true"><div class="item photo-5fa62fe8-ab51-596f-b295-18374af02a72 tnt-section-other tnt-sub-section-ads">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Larry A. Manross Sr., 88","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="/classifieds/other/ads/pdfdisplayad_5fa62fe8-ab51-596f-b295-18374af02a72.html" >
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/classifieds/5/fa/5fa62fe8-ab51-596f-b295-18374af02a72/5fc7a4ffea13f.preview.jpg?resize=1200%2C948"
                    
                    alt="Save A Lot"
                    class="img-responsive owl-first-image owl-lazy default"
                    width="1620"
                    height="1280"
                    data-src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/classifieds/5/fa/5fa62fe8-ab51-596f-b295-18374af02a72/5fc7a4ffea13f.preview.jpg?resize=1200%2C948" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-1600432 collapse in">
                    <div class="card-headline caption-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/other/ads/pdfdisplayad_5fa62fe8-ab51-596f-b295-18374af02a72.html" class="tnt-asset-link">
        

        
            Save A Lot</a></h4>
                    </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-387b1cf4-00fc-559a-b7ad-46c8a1895c03 hidden-print tnt-section-other tnt-sub-section-ads">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Larry A. Manross Sr., 88","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-vertical">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="/classifieds/other/ads/pdfdisplayad_387b1cf4-00fc-559a-b7ad-46c8a1895c03.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="ExpressCare"
                    class="img-responsive owl-lazy default"
                    width="659"
                    height="800"
                    data-src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/classifieds/3/87/387b1cf4-00fc-559a-b7ad-46c8a1895c03/5fc692c0542bf.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-1600432 collapse in">
                    <div class="card-headline caption-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/other/ads/pdfdisplayad_387b1cf4-00fc-559a-b7ad-46c8a1895c03.html" class="tnt-asset-link">
        

        
            ExpressCare</a></h4>
                    </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-99eb4ad9-b884-56d0-a0e1-013434732516 hidden-print tnt-section-other tnt-sub-section-ads">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Larry A. Manross Sr., 88","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae","app":"editorial","metric":""}'  data-count="3"  class="photo-container layout-vertical">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="/classifieds/other/ads/pdfdisplayad_99eb4ad9-b884-56d0-a0e1-013434732516.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Light of Love 2020"
                    class="img-responsive owl-lazy default"
                    width="1179"
                    height="1757"
                    data-src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/classifieds/9/9e/99eb4ad9-b884-56d0-a0e1-013434732516/5fc692c127699.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-1600432 collapse in">
                    <div class="card-headline caption-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/other/ads/pdfdisplayad_99eb4ad9-b884-56d0-a0e1-013434732516.html" class="tnt-asset-link">
        

        
            Light of Love 2020</a></h4>
                    </div>
                
            </div>
        </div>
    </div>
                        </div><div class="item photo-44b5459f-1584-56b8-b43e-6385782830cb hidden-print tnt-section-other tnt-sub-section-ads">
                            <div class="item-container">
                                
                                <div data-track-object='{"title":"Larry A. Manross Sr., 88","url":"/obituaries/article_26275634-3691-11eb-ac3e-af2aa9888fae.html","uuid":"26275634-3691-11eb-ac3e-af2aa9888fae","app":"editorial","metric":""}'  data-count="4"  class="photo-container layout-horizontal">
                                                <div class="loading-slide text-center"><i class="fas tnt-spinner tnt-spin"></i></div>
                                            
                                            
                                        
                                        <a href="/classifieds/other/ads/pdfdisplayad_44b5459f-1584-56b8-b43e-6385782830cb.html" >
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="Rent This Space"
                    class="img-responsive owl-lazy default"
                    width="1000"
                    height="600"
                    data-src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/classifieds/4/4b/44b5459f-1584-56b8-b43e-6385782830cb/5f9715bbcaa17.preview.jpg" />
                                        </a>
                                        <div class="clearfix"></div>
                                </div>
                                
        <div class="caption-container">
            <div class="caption-inner-1600432 collapse in">
                    <div class="card-headline caption-headline">
                        <h4 class="tnt-headline ">
        
             <a href="/classifieds/other/ads/pdfdisplayad_44b5459f-1584-56b8-b43e-6385782830cb.html" class="tnt-asset-link">
        

        
            Rent This Space</a></h4>
                    </div>
                
            </div>
        </div>
    </div>
                        </div>
            </template>
        </div>
        
        
    </div></section></div><div id="tncms-block-1600441" class="tncms-block hide-headline"><section id="block-1600441" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1600441 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/eedition/">
                
                Today's E-Edition
                
                    </a>
                
            </h3>
        </div>
    </div></div>
          
        
            
            <article id="card-feature-1600441-b3b13b36-a8a8-5962-a2c6-150f0fe46e03" class="clearfix card feature feature-overlay-none feature-hover-none letterbox-style-default has-image  tnt-section-eedition">
        <div class="card-container">
            <div class="stage-wrapper">
                <div class="centered-content-stage has-image"><div class="media-preview-b3b13b36-a8a8-5962-a2c6-150f0fe46e03 media-preview edition-asset" data-aspect="original"><figure class="photo layout-vertical letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/eedition/edition_b3b13b36-a8a8-5962-a2c6-150f0fe46e03.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Titusville Herald News"
                            class="img-responsive lazyload full default"
                            width="300"
                            height="474"
                            data-sizes="auto"
                            data-srcset="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/eedition/4/b2/4b2d9507-4910-5c01-9cc2-66d834659a1f/5fcb056c691b3.preview-300.jpg?resize=200%2C316 200w, https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/content/tncms/assets/v3/eedition/4/b2/4b2d9507-4910-5c01-9cc2-66d834659a1f/5fcb056c691b3.preview-300.jpg?resize=300%2C474 300w" />
                </a>
                
            </div>
            
        </figure></div>
                    <div class="centered-content-container content-overlay text-center vert-align-bottom">
                        <a href="/eedition/edition_b3b13b36-a8a8-5962-a2c6-150f0fe46e03.html"  class="centered-content-link content-overlay">
                            <span class="sr-only">Titusville Herald News</span>
                        </a>
                        <div class="centered-content"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/eedition/edition_b3b13b36-a8a8-5962-a2c6-150f0fe46e03.html" class="tnt-asset-link">
        

        
            Titusville Herald News</a></h4></div>
                            
                            
                        </div>
                    </div>
                    
                </div>
            </div></div>
    </article>
            
        
     
    </section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1600635" class="tncms-block"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1685433" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1685433" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1685433');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1685426" class="tncms-block"><section id="block-1685426" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1685426 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="https://twitter.com/@TitusvilleSport">
                
                Follow us on Twitter
                
                    </a>
                
            </h3>
        </div>
    </div></div></section></div><div id="tncms-block-1685428" class="tncms-block"><a class="twitter-timeline" href="https://twitter.com/@TitusvilleSport" data-height="500">Tweets by Titusville Herald Sports</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script><div class="padding-top padding-bottom"></div></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-1600337" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1600337" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1600337');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "><div id="tncms-block-1600668" class="tncms-block"><h3 class="text-center"><i>The Herald office is open 8 a.m. to 4 p.m., Monday through Friday, and is closed for most major holidays.</i></h3></div></div>
                <div class="row">
                    

<div id="footer-col-zero-one" class="col-md-5 col-sm-12">
        <div id="tncms-region-footer-col-four" class="tncms-region "></div>
    </div>
    
    
    <div id="footer-col-zero-two" class="col-md-7 col-sm-12">
        <div id="tncms-region-footer-col-zero" class="tncms-region "></div>
    <div id="footer-col-one" class="col-md-4 col-sm-6">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1600436" class="tncms-block"><section id="block-1600436" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1600436 ">
        <div class="block-title-inner">
            <h4>
                
                Contact
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-editorial"  href="/site/contact.html" >
                    <span class="nav-label">Editorial</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertising"  href="/site/advertising.html" >
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifiedslegal"  href="/site/contact.html" >
                    <span class="nav-label">Classifieds/Legal</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/site/contact.html" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-publisher"  href="/site/contact.html" >
                    <span class="nav-label">Publisher</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-one-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-6">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1600435" class="tncms-block"><section id="block-1600435" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1600435 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-news"  href="/news" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds" >
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-two-under" class="tncms-region "></div>
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-12">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1600386" class="tncms-block"><section id="block-1600386" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1600386 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-advertising"  href="/site/commercial_printing.html" >
                    <span class="nav-label">Advertising</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-circulation"  href="/site/forms/subscription_services" >
                    <span class="nav-label">Circulation</span>
                </a></li></ul></div>
        <div id="tncms-region-footer-col-three-under" class="tncms-region "></div>
    </div>
        
        
      
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                

<script type="text/javascript" language="javascript">
$(document).ready(function()
{
$('img').bind('contextmenu', function(e){
return false;
}).delay(6000);
});
</script>


            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-1728667" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1728667" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1728667');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("26275634-3691-11eb-ac3e-af2aa9888fae")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc14870.add('act', dmpData);_cc14870.bcp();
            });
        });
    
    </script>
    
    
<script language="javascript" type="text/javascript">
$(document).ready(function() {     
         
           

    
     //$('.eedition-settings-switch input').prop('checked', false).checkboxradio("refresh"); 
     

      
 }); 
</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.dff62462821a09a08cb5a44c8d59b2ea.js"></script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script src="https://bloximages.chicago2.vip.townnews.com/titusvilleherald.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc14870.add('act', serviceData);_cc14870.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc14870.add('act', dmpData);_cc14870.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>